Email functionality has been restored and is operating as expected. Our teams are continuing to closely monitor the service to ensure ongoing stability. We apologise for the inconvenience caused and thank you for your patience during this incident.
Posted Apr 21, 2026 - 09:18 BST
Update
We are continuing to investigate the issue affecting the email component of Elastic CX CCaaS. Our technical teams remain actively engaged and are progressing with investigation and remediation activities. At this time, email functionality is still impacted. We will provide a further update as soon as more information becomes available or once the issue is resolved. Thank you for your continued patience.
Posted Apr 21, 2026 - 09:08 BST
Investigating
Dear Customer,
We are currently experiencing an issue with the email component of our CCaaS cloud solution. As a result, email functionality is not working as expected.
Our technical teams are actively investigating and working to restore service as quickly as possible. We will provide an update once the issue is resolved or if further information becomes available.